Sonos – \"unable to play swyh.mp3 – the track is not encoded correctly\"

Home Forums Forum English (EN) Sonos – \"unable to play swyh.mp3 – the track is not encoded correctly\"

This topic contains 9 replies, has 1 voice, and was last updated by  Matthew 6 months, 1 week ago.

  • Author
  • #11750 Reply


    Thanks for this life saver app first of all.

    I can see my Sonos Play 1 by selecting the “Stream to” option but when I select it the Sonos desktop app refuses to play by pop up this error:
    “unable to play swyh.mp3 – the track is not encoded correctly”

    I know there is another method, adding the stream as a radio station but that has the time lag.

    Can we expect a solution to this problem?

    #11760 Reply


    i have the same problem connecting to my Sonos1. Connecting it as a radio station is working, though with a few seconds lag.
    If this bug is solved this program will get a donation from my side!

    #11761 Reply


    My sonos wont play either… Same message that its encoded incorrectly!! Any help or fixes available yet?

    #11763 Reply


    Me 4, any update yet?

    #11770 Reply

    kay schneutzer

    \”unable to play swyh.mp3 – the track is not encoded correctly\”

    same on my system – is there any solotion for that ?


    #11772 Reply



    you have to add a local radio station (HTTP Live Streaming).
    Just copy the url from the “Tools/HTTP Live Streamimng” context menu and add it to your sonos radio stations.


    #11778 Reply


    Hi Michael
    Couldn’t add a local radiostation’s URL on Sonos. Where could I find it, without having to select a specific Radio Station, rather then a URL?

    #11796 Reply

    Albert Chen

    I found several issues when I tried to broadcast Youtube audios to Sonos.

    The main issue is that the generated url by SWYH is sometimes incorrect.


    I have a VirtualBox installed on my laptop so I have more than 1 active ethernet interface (for non-technical people, it’s basically a network adapter…).

    Apparently when generating the HTTP stream url, SWYH doesn’t pick the actual IP address it’s using and use random one (or first one?) it gets from the windows system. Thanks for all the efforts but… sorry to say that… it is causing trouble for some people – someone may have more than 1 adapter enabled but hmm SWYH could only bind to one of the addresses.

    Another minor issue is that the suffix of the audio file never changes. Even if I choose stream with PCM/L16, it still gives a .mp3 suffix.

    So I manually assembled the url by looking at my adapter’s ip, with fixed port, with firewalls shutdown and it finally works for me.


    If you are a user:
    Not encoded correctly – I guess what’s happening is Sonos just got an error response and it tries to play it as a mp3, which causes error. If you meet this response it means you are not using the right url.
    1. Use start -> cmd -> ipconfig to check all interfaces you have. Try the IPs looks like ‘’ (if you are behind a router), instead of the one given by SWYH until this issue is fixed.
    2. Use ‘fixed port’ in SWYH Settings. Use mp3 first.
    3. Add Radio station to Sonos controller, you should add something like “”
    4. Shutdown your firewalls. You can always turn them back on later and see if it’s their fault.
    5. You can test the url from another device, which may be faster than changing the radio station in Sonos. Just use your iPhone or Android device, enter the url you think which might work and see if it could stream.

    To SWYH Developers,
    1. The HTTP Live Stream option should give the IP address SWYH service bound to, not a random one from the host ip list.
    2. The suffix should change accordingly.
    3. Thanks a lot for your excellent work!

    #11798 Reply

    Albert Chen

    OK. I’m wrong about one thing: the suffix is always mp3.

    #11810 Reply


    I had the same problem as users above – but my problem was I had a VPN connection active, and when I installed SWYH it took the IP address from the VPN connection. But Sonos could not connect through the VPN. So I disabled the VPN then uninstalled and reinstalled SWYH. Then going back to Tools > HTTP Live Streaming I saw the URL now had the regular IP address which I could see in cmd prompt, when running the “ipconfig” command. Thank you Albert Chen for the hints!!!

Reply To: Sonos – \"unable to play swyh.mp3 – the track is not encoded correctly\"
Your information:

47 + = 54

Posted in